default.nix 629 B

12345678910111213141516171819202122232425262728293031323334353637
  1. { nixpkgs ? import <nixpkgs>{} }:
  2. with nixpkgs;
  3. stdenv.mkDerivation rec {
  4. name = "cookbook";
  5. src = ./.;
  6. buildInputs = [
  7. git
  8. (texlive.combine {
  9. inherit (texlive)
  10. scheme-small
  11. latexmk
  12. ifmtarg
  13. booktabs
  14. units
  15. changepage
  16. hyperxmp
  17. doclicense
  18. xifthen
  19. etoolbox
  20. mfirstuc
  21. datatool
  22. glossaries
  23. textcase
  24. ;
  25. })
  26. ];
  27. buildPhase = "make";
  28. meta = with lib; {
  29. description = "Open Source Cookbook";
  30. license = licenses.cc-by-sa-40;
  31. author = "Samuel Flint <swflint@flintfam.org>";
  32. };
  33. }