default.nix 848 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. { nixpkgs ? import <nixpkgs> {} }:
  2. with nixpkgs;
  3. stdenv.mkDerivation rec {
  4. name = "open-cookbook";
  5. src = ./.;
  6. buildInputs = [
  7. git
  8. (
  9. texlive.combine {
  10. inherit (texlive)
  11. # Basic Packages
  12. scheme-small
  13. # Specifically used
  14. latexmk
  15. booktabs
  16. units
  17. changepage
  18. hyperxmp
  19. doclicense
  20. glossaries
  21. # Un-handled dependencies
  22. ifmtarg
  23. xifthen
  24. xfor
  25. substr
  26. etoolbox
  27. mfirstuc
  28. datatool
  29. textcase
  30. csquotes
  31. ccicons
  32. ;
  33. }
  34. )
  35. ];
  36. buildPhase = "make";
  37. meta = with lib; {
  38. description = "Open Source Cookbook";
  39. license = licenses.cc-by-sa-40;
  40. author = "Samuel Flint <swflint@flintfam.org>";
  41. };
  42. }