default.nix 866 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. { nixpkgs ? import <nixpkgs>{} }:
  2. with nixpkgs;
  3. let
  4. lemacs = emacsWithPackages(epkgs:
  5. (with epkgs.melpaPackages; [ess]) ++
  6. (with epkgs.orgPackages; [org-plus-contrib])
  7. );
  8. in
  9. stdenv.mkDerivation rec {
  10. name = "document";
  11. src = ./.;
  12. buildInputs = [
  13. # Emacs -- necessary for building tex file
  14. lemacs
  15. # TeX compilation
  16. (texlive.combine {
  17. inherit (texlive)
  18. scheme-small
  19. # Directly required packages
  20. latexmk
  21. epstopdf
  22. # Other Packages
  23. wrapfig
  24. capt-of
  25. csquotes
  26. xpatch
  27. pstricks
  28. ;
  29. })
  30. # Local Packages
  31. ];
  32. buildPhase = "make";
  33. # meta = with lib; {
  34. # description = "UNL LA Program Operations Manuals";
  35. # licenses = licenses.nonfree;
  36. # author = "LA Program <learningassistants@cse.unl.edu>";
  37. # };
  38. }