default.nix 753 B

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. { pkgs ? import <nixpkgs> { config = { }; overlays = [ ]; } }:
  2. let
  3. lemacs = emacsWithPackages (epkgs:
  4. (with epkgs.melpaPackages;
  5. [ ess ]
  6. ) ++
  7. (with epkgs.orgPackages; [ org-plus-contrib ])
  8. );
  9. tex = pkgs.texlive.combine {
  10. inherit (texlive)
  11. scheme-small
  12. latexmk
  13. epstopdf
  14. ;
  15. };
  16. gitignoreSource = pkgs.nix-gitignore.gitignoreFilterSourcePure (_: _: true);
  17. in
  18. pkgs.stdenv.mkDerivation {
  19. name = "document";
  20. src = gitignoreSource ./.gitignore ./.;
  21. buildInputs = [
  22. # Emacs -- necessary for building tex file
  23. lemacs
  24. tex
  25. ];
  26. buildPhase = "make";
  27. # meta = with lib; {
  28. # description = "Description";
  29. # licenses = licenses.nonfree;
  30. # author = "Name <email>";
  31. # };
  32. }