default.nix 615 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. { nixpkgs ? import <nixpkgs>{} }:
  2. with nixpkgs;
  3. stdenv.mkDerivation rec {
  4. name = "document";
  5. src = ./.;
  6. buildInputs = [
  7. (texlive.combine {
  8. inherit (texlive)
  9. scheme-small
  10. # Directly required packages
  11. latexmk
  12. csquotes
  13. everypage
  14. marginnote
  15. glossaries
  16. # Apparently required
  17. mfirstuc
  18. xfor
  19. datatool
  20. substr
  21. tracklang
  22. ;
  23. })
  24. ];
  25. buildPhase = "make";
  26. # meta = with lib; {
  27. # description = "Description";
  28. # licenses = licenses.nonfree;
  29. # author = "Name <email>";
  30. # };
  31. }