default.nix 539 B

1234567891011121314151617181920212223242526272829303132
  1. { pkgs ? import <nixpkgs> { config = { }; overlays = [ ]; } }:
  2. let
  3. tex = pkgs.texlive.combine {
  4. inherit (pkgs.texlive)
  5. scheme-small
  6. latexmk
  7. ;
  8. };
  9. gitignoreSource = pkgs.nix-gitignore.gitignoreFilterSourcePure (_: _: true);
  10. in
  11. pkgs.stdenv.mkDerivation {
  12. name = "document";
  13. src = gitignoreSource ./.gitignore ./.;
  14. buildInputs = [
  15. tex
  16. ];
  17. buildPhase = "make";
  18. # meta = with lib; {
  19. # description = "Description";
  20. # licenses = licenses.nonfree;
  21. # author = "Name <email>";
  22. # };
  23. }