1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253 |
- {
- description = "A custom synchronization tool";
- inputs = {
- nixpkgs.url = "github:NixOS/nixpkgs";
- utils.url = "github:numtide/flake-utils";
- };
- outputs = { self, nixpkgs, utils }:
- utils.lib.eachDefaultSystem (
- system:
- let
- pkgs = import nixpkgs { inherit system; };
- in
- rec {
- packages = rec {
- sync-it = pkgs.rustPlatform.buildRustPackage rec {
- name = "sync-it";
- version = "1.2.1";
- src = ./.;
- cargoSha256 = "Ey6PJVmJXd2wCXemKfAHJ+EDVPtQezayuvOjQGQNGeU=";
- meta = with pkgs.stdenv.lib; {
- description = "A simple, customizable synchronization tool.";
- license = licenses.gpl3Plus;
- maintainers = with maintainers; [ swflint ];
- };
- };
- devEnvironment = pkgs.mkShell {
- name = "sync-it-dev-environment";
- buildInputs = [
- pkgs.pre-commit
- pkgs.rustc
- pkgs.cargo
- pkgs.rls
- pkgs.clippy
- pkgs.rustfmt
- pkgs.sloc
- ];
- };
- };
- defaultPackage = packages.sync-it;
- devShell = packages.devEnvironment;
- }
- );
- }
|