flake.nix 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. {
  2. description = "A custom synchronization tool";
  3. inputs = {
  4. nixpkgs.url = "github:NixOS/nixpkgs";
  5. utils.url = "github:numtide/flake-utils";
  6. };
  7. outputs = { self, nixpkgs, utils }:
  8. utils.lib.eachDefaultSystem (system:
  9. let
  10. pkgs = import nixpkgs { inherit system; };
  11. in
  12. rec {
  13. packages = rec {
  14. # sync-it = pkgs.rustPlatform.buildRustPackage rec {
  15. # name = "sync-it";
  16. # version = "0.0.1";
  17. # cargoSha256 = "XXX";
  18. # meta = with pkgs.stdenv.lib; {
  19. # description = "A simple, customizable synchronization tool.";
  20. # license = licenses.gpl3OrLater;
  21. # maintainers = with maintainers; [ swflint ];
  22. # };
  23. # };
  24. devEnvironment = pkgs.mkShell {
  25. name = "sync-it-dev-environment";
  26. buildInputs = [
  27. pkgs.pre-commit
  28. pkgs.rustc
  29. pkgs.cargo
  30. ];
  31. };
  32. };
  33. devShell = packages.devEnvironment;
  34. }
  35. );
  36. }